aboutsummaryrefslogtreecommitdiff
path: root/deployments/ts-service-test/linux-pc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'deployments/ts-service-test/linux-pc/CMakeLists.txt')
-rw-r--r--deployments/ts-service-test/linux-pc/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/deployments/ts-service-test/linux-pc/CMakeLists.txt b/deployments/ts-service-test/linux-pc/CMakeLists.txt
index 8ccc3b3c5..85a0a36f2 100644
--- a/deployments/ts-service-test/linux-pc/CMakeLists.txt
+++ b/deployments/ts-service-test/linux-pc/CMakeLists.txt
@@ -64,6 +64,18 @@ unit_test_add_suite(
target_include_directories(ts-service-test PRIVATE "${TOP_LEVEL_INCLUDE_DIRS}")
#-------------------------------------------------------------------------------
+# Components that are specific to deployment in the linux-pc environment.
+#
+#-------------------------------------------------------------------------------
+add_components(
+ TARGET "ts-service-test"
+ BASE_DIR ${TS_ROOT}
+ COMPONENTS
+ "components/service/test_runner/client/cpp"
+ "components/service/test_runner/test/service"
+)
+
+#-------------------------------------------------------------------------------
# Extend with components that are common across all deployments of
# ts-service-test
#