aboutsummaryrefslogtreecommitdiff
path: root/deployments/ts-demo/arm-linux/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'deployments/ts-demo/arm-linux/CMakeLists.txt')
-rw-r--r--deployments/ts-demo/arm-linux/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/deployments/ts-demo/arm-linux/CMakeLists.txt b/deployments/ts-demo/arm-linux/CMakeLists.txt
new file mode 100644
index 000000000..8b2fcf431
--- /dev/null
+++ b/deployments/ts-demo/arm-linux/CMakeLists.txt
@@ -0,0 +1,33 @@
+#-------------------------------------------------------------------------------
+# Copyright (c) 2020, Arm Limited and Contributors. All rights reserved.
+#
+# SPDX-License-Identifier: BSD-3-Clause
+#
+#-------------------------------------------------------------------------------
+cmake_minimum_required(VERSION 3.16)
+include(../../deployment.cmake REQUIRED)
+
+#-------------------------------------------------------------------------------
+# The CMakeLists.txt for building the ts-demo deployment for arm-linux
+#
+# Used for building and running service level tests from Linux user-space
+# on an Arm platform with real deployments of trusted services.
+#-------------------------------------------------------------------------------
+include(${TS_ROOT}/environments/arm-linux/env.cmake)
+project(trusted-services LANGUAGES CXX C)
+add_executable(ts-demo)
+target_include_directories(ts-demo PRIVATE "${TOP_LEVEL_INCLUDE_DIRS}")
+
+#-------------------------------------------------------------------------------
+# Extend with components that are common across all deployments of
+# ts-demo
+#
+#-------------------------------------------------------------------------------
+include(../ts-demo.cmake REQUIRED)
+
+#-------------------------------------------------------------------------------
+# Define library options and dependencies.
+#
+#-------------------------------------------------------------------------------
+env_set_link_options(TGT ts-demo)
+target_link_libraries(ts-demo PRIVATE stdc++ gcc m)