aboutsummaryrefslogtreecommitdiff
path: root/deployments/component-test/linux-pc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'deployments/component-test/linux-pc/CMakeLists.txt')
-rw-r--r--deployments/component-test/linux-pc/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/deployments/component-test/linux-pc/CMakeLists.txt b/deployments/component-test/linux-pc/CMakeLists.txt
index 3e56d8388..a3ed94977 100644
--- a/deployments/component-test/linux-pc/CMakeLists.txt
+++ b/deployments/component-test/linux-pc/CMakeLists.txt
@@ -64,6 +64,17 @@ unit_test_add_suite(
target_include_directories(component-test PRIVATE "${TOP_LEVEL_INCLUDE_DIRS}")
#-------------------------------------------------------------------------------
+# Components that are specific to deployment in the linux-pc environment.
+#
+#-------------------------------------------------------------------------------
+add_components(
+ TARGET "component-test"
+ BASE_DIR ${TS_ROOT}
+ COMPONENTS
+ "components/service/crypto/provider/mbedcrypto/entropy_adapter/linux"
+)
+
+#-------------------------------------------------------------------------------
# Extend with components that are common across all deployments of
# component-test
#