aboutsummaryrefslogtreecommitdiff
path: root/deployments/component-test/arm-linux/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'deployments/component-test/arm-linux/CMakeLists.txt')
-rw-r--r--deployments/component-test/arm-linux/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/deployments/component-test/arm-linux/CMakeLists.txt b/deployments/component-test/arm-linux/CMakeLists.txt
index d96a793a3..a0ad971f7 100644
--- a/deployments/component-test/arm-linux/CMakeLists.txt
+++ b/deployments/component-test/arm-linux/CMakeLists.txt
@@ -1,5 +1,5 @@
#-------------------------------------------------------------------------------
-# Copyright (c) 2020, Arm Limited and Contributors. All rights reserved.
+# Copyright (c) 2020-2021, Arm Limited and Contributors. All rights reserved.
#
# SPDX-License-Identifier: BSD-3-Clause
#
@@ -29,6 +29,17 @@ include(${TS_ROOT}/external/CppUTest/CppUTest.cmake)
target_link_libraries(component-test PRIVATE CppUTest)
#-------------------------------------------------------------------------------
+# Components that are specific to deployment in the arm-linux environment.
+#
+#-------------------------------------------------------------------------------
+add_components(
+ TARGET "component-test"
+ BASE_DIR ${TS_ROOT}
+ COMPONENTS
+ "components/service/crypto/provider/mbedcrypto/entropy_adapter/linux"
+)
+
+#-------------------------------------------------------------------------------
# Extend with components that are common across all deployments of
# component-test
#