aboutsummaryrefslogtreecommitdiff
path: root/deployments/component-test/arm-linux/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'deployments/component-test/arm-linux/CMakeLists.txt')
-rw-r--r--deployments/component-test/arm-linux/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/deployments/component-test/arm-linux/CMakeLists.txt b/deployments/component-test/arm-linux/CMakeLists.txt
new file mode 100644
index 000000000..4b3353c67
--- /dev/null
+++ b/deployments/component-test/arm-linux/CMakeLists.txt
@@ -0,0 +1,34 @@
+#-------------------------------------------------------------------------------
+# Copyright (c) 2020, Arm Limited and Contributors. All rights reserved.
+#
+# SPDX-License-Identifier: BSD-3-Clause
+#
+#-------------------------------------------------------------------------------
+cmake_minimum_required(VERSION 3.16)
+include(../../deployment.cmake REQUIRED)
+
+#-------------------------------------------------------------------------------
+# The CMakeLists.txt for building the component-test deployment for arm-linux
+#
+# Used for building and running component level tests as a Linux userspace
+# program running on Arm. Tests can be run by running the built executable
+# called "component-test"
+#-------------------------------------------------------------------------------
+include(${TS_ROOT}/environments/arm-linux/env.cmake)
+project(trusted-services LANGUAGES CXX C)
+add_executable(component-test)
+target_include_directories(component-test PRIVATE "${TOP_LEVEL_INCLUDE_DIRS}")
+
+#-------------------------------------------------------------------------------
+# Extend with components that are common across all deployments of
+# component-test
+#
+#-------------------------------------------------------------------------------
+include(../component-test.cmake REQUIRED)
+
+#-------------------------------------------------------------------------------
+# Define library options and dependencies.
+#
+#-------------------------------------------------------------------------------
+env_set_link_options(TGT component-test)
+target_link_libraries(component-test PRIVATE stdc++ gcc m)