aboutsummaryrefslogtreecommitdiff
path: root/deployments/component-test/arm-linux/CMakeLists.txt
diff options
context:
space:
mode:
authorjulhal01 <julian.hall@arm.com>2021-01-20 13:51:58 +0000
committerGyorgy Szing <Gyorgy.Szing@arm.com>2021-04-14 16:59:13 +0200
commitffa98d8e11e5630b9b5afc3cfacc2757e196088d (patch)
tree16e1d3ebf8cae8138547b09acd9126c91975eb3f /deployments/component-test/arm-linux/CMakeLists.txt
parent734dbad7305293aad19f517c29f01db5d41495ab (diff)
downloadtrusted-services-ffa98d8e11e5630b9b5afc3cfacc2757e196088d.tar.gz
Add platform support
TS project structure and build system extended to accommodate hardware specific drivers. The concept of a platform is introduced to allow hardware specific drivers from external providers to be used. This change implements the Portability Model described in the project documentation. Signed-off-by: Julian Hall <julian.hall@arm.com> Change-Id: I61e678ae103e0bf139f2c440ba6cd010620af37e
Diffstat (limited to 'deployments/component-test/arm-linux/CMakeLists.txt')
-rw-r--r--deployments/component-test/arm-linux/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/deployments/component-test/arm-linux/CMakeLists.txt b/deployments/component-test/arm-linux/CMakeLists.txt
index d96a793a3..a0ad971f7 100644
--- a/deployments/component-test/arm-linux/CMakeLists.txt
+++ b/deployments/component-test/arm-linux/CMakeLists.txt
@@ -1,5 +1,5 @@
#-------------------------------------------------------------------------------
-# Copyright (c) 2020, Arm Limited and Contributors. All rights reserved.
+# Copyright (c) 2020-2021, Arm Limited and Contributors. All rights reserved.
#
# SPDX-License-Identifier: BSD-3-Clause
#
@@ -29,6 +29,17 @@ include(${TS_ROOT}/external/CppUTest/CppUTest.cmake)
target_link_libraries(component-test PRIVATE CppUTest)
#-------------------------------------------------------------------------------
+# Components that are specific to deployment in the arm-linux environment.
+#
+#-------------------------------------------------------------------------------
+add_components(
+ TARGET "component-test"
+ BASE_DIR ${TS_ROOT}
+ COMPONENTS
+ "components/service/crypto/provider/mbedcrypto/entropy_adapter/linux"
+)
+
+#-------------------------------------------------------------------------------
# Extend with components that are common across all deployments of
# component-test
#