aboutsummaryrefslogtreecommitdiff
path: root/platform/ext/target/nxp/lpcxpresso55s69/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'platform/ext/target/nxp/lpcxpresso55s69/CMakeLists.txt')
-rw-r--r--platform/ext/target/nxp/lpcxpresso55s69/CMakeLists.txt329
1 files changed, 177 insertions, 152 deletions
diff --git a/platform/ext/target/nxp/lpcxpresso55s69/CMakeLists.txt b/platform/ext/target/nxp/lpcxpresso55s69/CMakeLists.txt
index 4c21e68c6c..620705d3c0 100644
--- a/platform/ext/target/nxp/lpcxpresso55s69/CMakeLists.txt
+++ b/platform/ext/target/nxp/lpcxpresso55s69/CMakeLists.txt
@@ -1,12 +1,26 @@
#-------------------------------------------------------------------------------
-# Copyright (c) 2020-2021, Arm Limited. All rights reserved.
+# Copyright (c) 2020-2024, Arm Limited. All rights reserved.
# Copyright (c) 2020, Linaro. All rights reserved.
+# Copyright 2021-2024 NXP. All rights reserved.
#
# SPDX-License-Identifier: BSD-3-Clause
#
#-------------------------------------------------------------------------------
cmake_policy(SET CMP0076 NEW)
+
+set(NXP_COMMON_DIR ${CMAKE_CURRENT_LIST_DIR}/../common)
+
+# Pull drivers from NXP git
+if (TFM_PLATFORM_NXP_HAL_FILE_PATH STREQUAL "DOWNLOAD")
+ set(NXP_HAL_FILE_PATH ${PLATFORM_DIR}/ext/target/nxp)
+ Message("-- Pulling MCUxpresso NXP SDK drivers from https://github.com/NXPmicro/mcux-sdk")
+ include(pull_drivers.cmake)
+# Use specified path to NXP hal folder provided by user
+else()
+ set(NXP_HAL_FILE_PATH ${TFM_PLATFORM_NXP_HAL_FILE_PATH})
+endif()
+
set(CMAKE_CURRENT_SOURCE_DIR ${CMAKE_CURRENT_LIST_DIR})
string(TOLOWER "${CMAKE_BUILD_TYPE}" BUILD_TYPE_LOWER)
@@ -27,37 +41,23 @@ target_include_directories(platform_region_defs
# Specify the location of platform specific build dependencies.
target_sources(tfm_s
PRIVATE
- $<$<C_COMPILER_ID:GNU>:${CMAKE_CURRENT_SOURCE_DIR}/Device/Source/armgcc/startup_LPC55S69_cm33_core0_s.S>
- $<$<C_COMPILER_ID:IAR>:${CMAKE_CURRENT_SOURCE_DIR}/Device/Source/iar/startup_LPC55S69_cm33_core0_s.s>
+ ${CMAKE_CURRENT_SOURCE_DIR}/Device/Source/startup_lpcxpresso55s69.c
)
target_add_scatter_file(tfm_s
- $<$<C_COMPILER_ID:GNU>:${CMAKE_SOURCE_DIR}/platform/ext/common/gcc/tfm_common_s.ld>
- $<$<C_COMPILER_ID:IAR>:${CMAKE_SOURCE_DIR}/platform/ext/common/iar/tfm_common_s.icf>
+ $<$<C_COMPILER_ID:ARMClang>:${PLATFORM_DIR}/ext/common/armclang/tfm_common_s.sct>
+ $<$<C_COMPILER_ID:GNU>:${PLATFORM_DIR}/ext/common/gcc/tfm_common_s.ld>
+ $<$<C_COMPILER_ID:IAR>:${PLATFORM_DIR}/ext/common/iar/tfm_common_s.icf>
)
-if(NS)
- target_sources(tfm_ns
- PRIVATE
- $<$<C_COMPILER_ID:GNU>:${CMAKE_CURRENT_SOURCE_DIR}/Device/Source/armgcc/startup_LPC55S69_cm33_core0_ns.S>
- $<$<C_COMPILER_ID:IAR>:${CMAKE_CURRENT_SOURCE_DIR}/Device/Source/iar/startup_LPC55S69_cm33_core0_ns.s>
- )
- target_add_scatter_file(tfm_ns
- $<$<C_COMPILER_ID:GNU>:${CMAKE_CURRENT_SOURCE_DIR}/Device/Source/armgcc/LPC55S69_cm33_core0_ns.ld>
- $<$<C_COMPILER_ID:IAR>:${CMAKE_CURRENT_SOURCE_DIR}/Device/Source/iar/LPC55S69_cm33_core0_ns.icf>
- )
- target_link_libraries(CMSIS_5_tfm_ns
- INTERFACE
- CMSIS_5_RTX_V8MMN
- )
-endif()
-
if(BL2)
target_sources(bl2
PRIVATE
- $<$<C_COMPILER_ID:GNU>:${CMAKE_CURRENT_SOURCE_DIR}/Device/Source/armgcc/startup_LPC55S69_cm33_core0_bl2.S>
+ ${CMAKE_CURRENT_SOURCE_DIR}/Device/Source/startup_lpcxpresso55s69.c
)
target_add_scatter_file(bl2
- $<$<C_COMPILER_ID:GNU>:${CMAKE_CURRENT_SOURCE_DIR}/Device/Source/armgcc/LPC55S69_cm33_core0_bl2.ld>
+ $<$<C_COMPILER_ID:ARMClang>:${PLATFORM_DIR}/ext/common/armclang/tfm_common_bl2.sct>
+ $<$<C_COMPILER_ID:GNU>:${PLATFORM_DIR}/ext/common/gcc/tfm_common_bl2.ld>
+ $<$<C_COMPILER_ID:IAR>:${PLATFORM_DIR}/ext/common/iar/tfm_common_bl2.icf>
)
endif()
@@ -66,56 +66,61 @@ endif()
target_include_directories(platform_s
PUBLIC
.
- Native_Driver
- Native_Driver/project_template/s
- Device/Config
Device/Include
+ project_template/s
partition
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/components/lists
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/components/serial_manager
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/components/uart
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/drivers
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/utilities/debug_console
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/utilities/str
+ ../../arm/drivers/mpu/armv8m
+ ${PLATFORM_DIR}/ext/target/nxp/common
+ ${PLATFORM_DIR}/ext/target/nxp/common/CMSIS_Driver
+ ${PLATFORM_DIR}/ext/target/nxp/common/Device/Config
+ ${PLATFORM_DIR}/ext/target/nxp/common/Device/Include
+ ${NXP_HAL_FILE_PATH}/lpcxpresso55s69/Native_Driver
+ ${NXP_HAL_FILE_PATH}/lpcxpresso55s69/Native_Driver/drivers
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/drivers
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/components/lists
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/components/serial_manager
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/components/uart
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/utilities/debug_console
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/utilities/str
)
target_sources(platform_s
+ INTERFACE
+ $<$<STREQUAL:"${TFM_FIH_PROFILE}","HIGH">:${PLATFORM_DIR}/ext/common/template/tfm_fih_rng.c>
PRIVATE
- target_cfg.c
- spm_hal.c
- tfm_hal_isolation.c
- Native_Driver/project_template/s/board.c
- Native_Driver/project_template/s/clock_config.c
- Native_Driver/project_template/s/peripherals.c
- Native_Driver/project_template/s/pin_mux.c
- Native_Driver/system_LPC55S69_cm33_core0.c
- ../common/CMSIS_Driver/Driver_Flash.c
- ../common/CMSIS_Driver/Driver_USART.c
- ../common/Native_Driver/components/lists/generic_list.c
- ../common/Native_Driver/components/serial_manager/serial_manager.c
- ../common/Native_Driver/components/serial_manager/serial_port_uart.c
- ../common/Native_Driver/components/uart/usart_adapter.c
- ../common/Native_Driver/drivers/fsl_casper.c
- ../common/Native_Driver/drivers/fsl_clock.c
- ../common/Native_Driver/drivers/fsl_common.c
- ../common/Native_Driver/drivers/fsl_ctimer.c
- ../common/Native_Driver/drivers/fsl_flexcomm.c
- ../common/Native_Driver/drivers/fsl_gpio.c
- ../common/Native_Driver/drivers/fsl_hashcrypt.c
- ../common/Native_Driver/drivers/fsl_iap.c
- ../common/Native_Driver/drivers/fsl_power.c
- ../common/Native_Driver/drivers/fsl_reset.c
- ../common/Native_Driver/drivers/fsl_rng.c
- ../common/Native_Driver/drivers/fsl_usart.c
- ../common/Native_Driver/utilities/fsl_assert.c
- ../common/Native_Driver/utilities/fsl_sbrk.c
- ../common/Native_Driver/utilities/debug_console/fsl_debug_console.c
- ../common/Native_Driver/utilities/str/fsl_str.c
- ../common/Native_Driver/mpu_armv8m_drv.c
- ${CMAKE_SOURCE_DIR}/platform/ext/common/tfm_hal_isolation_mpu_v8m.c
- $<$<BOOL:${TFM_PARTITION_PLATFORM}>:${CMAKE_CURRENT_SOURCE_DIR}/plat_test.c>
- $<$<BOOL:${TFM_PARTITION_PLATFORM}>:${CMAKE_CURRENT_SOURCE_DIR}/services/src/tfm_platform_system.c>
+ ${NXP_COMMON_DIR}/CMSIS_Driver/Driver_Flash_iap1.c
+ ${NXP_COMMON_DIR}/CMSIS_Driver/Driver_USART.c
+ ../../arm/drivers/mpu/armv8m/mpu_armv8m_drv.c
+ project_template/s/board.c
+ project_template/s/clock_config.c
+ project_template/s/pin_mux.c
+ ${NXP_HAL_FILE_PATH}/lpcxpresso55s69/Native_Driver/system_LPC55S69_cm33_core0.c
+ ${NXP_HAL_FILE_PATH}/lpcxpresso55s69/Native_Driver/drivers/fsl_clock.c
+ ${NXP_HAL_FILE_PATH}/lpcxpresso55s69/Native_Driver/drivers/fsl_power.c
+ ${NXP_HAL_FILE_PATH}/lpcxpresso55s69/Native_Driver/drivers/fsl_reset.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/components/lists/fsl_component_generic_list.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/components/serial_manager/fsl_component_serial_manager.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/components/serial_manager/fsl_component_serial_port_uart.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/components/uart/fsl_adapter_usart.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/drivers/fsl_common.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/drivers/fsl_common_arm.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/drivers/fsl_ctimer.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/drivers/fsl_flexcomm.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/drivers/fsl_gpio.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/drivers/fsl_iap.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/drivers/fsl_usart.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/utilities/fsl_assert.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/utilities/debug_console/fsl_debug_console.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/utilities/str/fsl_str.c
+ $<$<BOOL:${TFM_PARTITION_PLATFORM}>:${PLATFORM_DIR}/ext/target/nxp/common/plat_test.c>
+ $<$<BOOL:${TFM_PARTITION_PLATFORM}>:${PLATFORM_DIR}/ext/target/nxp/common/services/src/tfm_platform_system.c>
+)
+
+target_link_libraries(platform_s
+ PRIVATE
+ # For attest HAL strnlen
+ tfm_sprt
)
target_compile_options(platform_s
@@ -130,57 +135,7 @@ target_compile_options(platform_s
# fix is compatible.
target_sources(tfm_s
PRIVATE
- Native_Driver/project_template/s/hardware_init.c
-)
-
-#========================= Platform Non-Secure ================================#
-
-target_include_directories(platform_ns
- PUBLIC
- .
- Device/Config
- Device/Include
- Native_Driver
- Native_Driver/project_template/ns
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/components/lists
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/components/serial_manager
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/components/uart
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/drivers
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/utilities/debug_console
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/utilities/str
-)
-
-target_sources(platform_ns
- PRIVATE
- Native_Driver/system_LPC55S69_cm33_core0.c
- Native_Driver/project_template/ns/board.c
- Native_Driver/project_template/ns/hardware_init.c
- Native_Driver/project_template/ns/clock_config.c
- Native_Driver/project_template/ns/peripherals.c
- Native_Driver/project_template/ns/pin_mux.c
- ${PLATFORM_DIR}/ext/target/nxp/common/CMSIS_Driver/Driver_USART.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/components/lists/generic_list.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/components/serial_manager/serial_manager.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/components/serial_manager/serial_port_uart.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/components/uart/usart_adapter.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/drivers/fsl_casper.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/drivers/fsl_clock.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/drivers/fsl_common.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/drivers/fsl_ctimer.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/drivers/fsl_flexcomm.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/drivers/fsl_gpio.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/drivers/fsl_hashcrypt.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/drivers/fsl_iap.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/drivers/fsl_power.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/drivers/fsl_reset.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/drivers/fsl_rng.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/drivers/fsl_usart.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/utilities/fsl_assert.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/utilities/fsl_sbrk.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/utilities/debug_console/fsl_debug_console.c
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/utilities/str/fsl_str.c
- $<$<BOOL:${TFM_PARTITION_PLATFORM}>:${CMAKE_CURRENT_SOURCE_DIR}/plat_test.c>
- $<$<BOOL:${TFM_PARTITION_PLATFORM}>:${CMAKE_CURRENT_SOURCE_DIR}/services/src/tfm_platform_system.c>
+ project_template/s/hardware_init.c
)
#========================= Platform BL2 =======================================#
@@ -190,44 +145,44 @@ if(BL2)
PUBLIC
partition
Device/Include
- Native_Driver
- Native_Driver/project_template/bl2
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/drivers
+ project_template/bl2
+ ${PLATFORM_DIR}/ext/target/nxp/common
+ ${PLATFORM_DIR}/ext/target/nxp/common/Device/Include
+ ${NXP_HAL_FILE_PATH}/lpcxpresso55s69/Native_Driver
+ ${NXP_HAL_FILE_PATH}/lpcxpresso55s69/Native_Driver/drivers
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/drivers
PRIVATE
.
- Device/Config
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/components/serial_manager
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/components/uart
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/utilities/debug_console
- ${PLATFORM_DIR}/ext/target/nxp/common/Native_Driver/utilities/str
+ ${PLATFORM_DIR}/ext/target/nxp/common/Device/Config
+ ${PLATFORM_DIR}/ext/target/nxp/common/Device/Include
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/components/serial_manager
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/components/uart
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/utilities/debug_console
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/utilities/str
)
target_sources(platform_bl2
PRIVATE
- boot_hal.c
- Native_Driver/project_template/bl2/board.c
- Native_Driver/project_template/bl2/clock_config.c
- Native_Driver/project_template/bl2/pin_mux.c
- Native_Driver/system_LPC55S69_cm33_core0.c
- ../common/CMSIS_Driver/Driver_Flash.c
- ../common/CMSIS_Driver/Driver_USART.c
- ../common/Native_Driver/components/serial_manager/serial_manager.c
- ../common/Native_Driver/components/serial_manager/serial_port_uart.c
- ../common/Native_Driver/components/uart/usart_adapter.c
- ../common/Native_Driver/drivers/fsl_casper.c
- ../common/Native_Driver/drivers/fsl_clock.c
- ../common/Native_Driver/drivers/fsl_common.c
- ../common/Native_Driver/drivers/fsl_flexcomm.c
- ../common/Native_Driver/drivers/fsl_hashcrypt.c
- ../common/Native_Driver/drivers/fsl_iap.c
- ../common/Native_Driver/drivers/fsl_power.c
- ../common/Native_Driver/drivers/fsl_reset.c
- ../common/Native_Driver/drivers/fsl_rng.c
- ../common/Native_Driver/drivers/fsl_usart.c
- ../common/Native_Driver/utilities/fsl_assert.c
- ../common/Native_Driver/utilities/fsl_sbrk.c
- ../common/Native_Driver/utilities/debug_console/fsl_debug_console.c
- ../common/Native_Driver/utilities/str/fsl_str.c
+ project_template/bl2/board.c
+ project_template/bl2/clock_config.c
+ project_template/bl2/pin_mux.c
+ ${NXP_COMMON_DIR}/CMSIS_Driver/Driver_Flash_iap1.c
+ ${NXP_COMMON_DIR}/CMSIS_Driver/Driver_USART.c
+ ${NXP_HAL_FILE_PATH}/lpcxpresso55s69/Native_Driver/system_LPC55S69_cm33_core0.c
+ ${NXP_HAL_FILE_PATH}/lpcxpresso55s69/Native_Driver/drivers/fsl_clock.c
+ ${NXP_HAL_FILE_PATH}/lpcxpresso55s69/Native_Driver/drivers/fsl_power.c
+ ${NXP_HAL_FILE_PATH}/lpcxpresso55s69/Native_Driver/drivers/fsl_reset.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/components/serial_manager/fsl_component_serial_manager.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/components/serial_manager/fsl_component_serial_port_uart.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/components/uart/fsl_adapter_usart.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/drivers/fsl_common.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/drivers/fsl_common_arm.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/drivers/fsl_flexcomm.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/drivers/fsl_iap.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/drivers/fsl_usart.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/utilities/fsl_assert.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/utilities/debug_console/fsl_debug_console.c
+ ${NXP_HAL_FILE_PATH}/common/Native_Driver/utilities/str/fsl_str.c
)
# GNU ld has some strange behaviour to do with weak functions, and does not deal
@@ -237,6 +192,76 @@ if(BL2)
# fix is compatible.
target_sources(bl2
PRIVATE
- Native_Driver/project_template/bl2/hardware_init.c
+ project_template/bl2/hardware_init.c
)
endif()
+
+#========================= tfm_spm ============================================#
+
+target_sources(tfm_spm
+ PRIVATE
+ target_cfg.c
+ ${NXP_COMMON_DIR}/tfm_hal_isolation.c
+ ${NXP_COMMON_DIR}/tfm_hal_platform.c
+)
+
+# If this is not added to the tfm_s it will not correctly override the weak
+# default handlers declared in assemebly, and will instead be discarded as they
+# are not in use.
+target_sources(tfm_s
+ PRIVATE
+ ${NXP_COMMON_DIR}/mpc_ppc_faults.c
+)
+
+#========================= Files for building NS side platform ================#
+
+install(FILES ${TARGET_PLATFORM_PATH}/project_template/ns/board.c
+ ${TARGET_PLATFORM_PATH}/project_template/ns/hardware_init.c
+ ${TARGET_PLATFORM_PATH}/project_template/ns/clock_config.c
+ ${TARGET_PLATFORM_PATH}/project_template/ns/pin_mux.c
+ ${NXP_COMMON_DIR}/CMSIS_Driver/Driver_USART.c
+ $<$<BOOL:${TFM_PARTITION_PLATFORM}>:${PLATFORM_DIR}/ext/target/nxp/common/plat_test.c>
+ DESTINATION ${INSTALL_PLATFORM_NS_DIR})
+
+install(DIRECTORY ${NXP_COMMON_DIR}/Device
+ DESTINATION ${INSTALL_PLATFORM_NS_DIR})
+
+install(DIRECTORY ${TARGET_PLATFORM_PATH}/Device
+ DESTINATION ${INSTALL_PLATFORM_NS_DIR})
+
+install(DIRECTORY ${NXP_HAL_FILE_PATH}/lpcxpresso55s69/Native_Driver
+ DESTINATION ${INSTALL_PLATFORM_NS_DIR})
+
+install(DIRECTORY ${NXP_HAL_FILE_PATH}/common/Native_Driver
+ DESTINATION ${INSTALL_PLATFORM_NS_DIR})
+
+install(FILES ${PLATFORM_DIR}/ext/driver/Driver_Common.h
+ ${PLATFORM_DIR}/ext/driver/Driver_Flash.h
+ ${PLATFORM_DIR}/ext/driver/Driver_USART.h
+ DESTINATION ${INSTALL_PLATFORM_NS_DIR}/ext/driver)
+
+install(FILES ${TARGET_PLATFORM_PATH}/project_template/ns/app.h
+ ${TARGET_PLATFORM_PATH}/project_template/ns/board.h
+ ${TARGET_PLATFORM_PATH}/project_template/ns/clock_config.h
+ ${TARGET_PLATFORM_PATH}/project_template/ns/pin_mux.h
+ ${TARGET_PLATFORM_PATH}/config_tfm_target.h
+ ${TARGET_PLATFORM_PATH}/target_cfg.h
+ ${TARGET_PLATFORM_PATH}/tfm_peripherals_def.h
+ ${NXP_COMMON_DIR}/target_cfg_common.h
+ DESTINATION ${INSTALL_PLATFORM_NS_DIR}/include)
+
+install(DIRECTORY ${TARGET_PLATFORM_PATH}/partition
+ DESTINATION ${INSTALL_PLATFORM_NS_DIR})
+
+install(FILES ${PLATFORM_DIR}/ext/common/gcc/tfm_common_ns.ld
+ ${PLATFORM_DIR}/ext/common/armclang/tfm_common_ns.sct
+ ${PLATFORM_DIR}/ext/common/iar/tfm_common_ns.icf
+ DESTINATION ${INSTALL_PLATFORM_NS_DIR}/linker_scripts)
+
+# copy all files from active platform directory
+install(DIRECTORY ${TARGET_PLATFORM_PATH}/ns/
+ DESTINATION ${INSTALL_PLATFORM_NS_DIR})
+
+install(FILES ${TARGET_PLATFORM_PATH}/cpuarch.cmake
+ ${TARGET_PLATFORM_PATH}/config.cmake
+ DESTINATION ${INSTALL_PLATFORM_NS_DIR})