aboutsummaryrefslogtreecommitdiff
path: root/platform/ext/accelerator/cc312/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'platform/ext/accelerator/cc312/CMakeLists.txt')
-rw-r--r--platform/ext/accelerator/cc312/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/platform/ext/accelerator/cc312/CMakeLists.txt b/platform/ext/accelerator/cc312/CMakeLists.txt
index 7da3bff410..5a6a96c1e3 100644
--- a/platform/ext/accelerator/cc312/CMakeLists.txt
+++ b/platform/ext/accelerator/cc312/CMakeLists.txt
@@ -81,7 +81,8 @@ if(BL2)
target_compile_options(bl2_mbedcrypto
PRIVATE
- -Wno-unused-parameter
+ $<$<C_COMPILER_ID:GNU>:-Wno-unused-parameter>
+ $<$<C_COMPILER_ID:ARMClang>:-Wno-unused-parameter>
)
#Include platform specific defs (registers etc)
@@ -160,7 +161,8 @@ target_compile_definitions(crypto_service_mbedcrypto
target_compile_options(crypto_service_mbedcrypto
PRIVATE
- -Wno-unused-parameter
+ $<$<C_COMPILER_ID:GNU>:-Wno-unused-parameter>
+ $<$<C_COMPILER_ID:ARMClang>:-Wno-unused-parameter>
)
#Include platform specific defs (registers etc)