aboutsummaryrefslogtreecommitdiff
path: root/platform/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'platform/CMakeLists.txt')
-rwxr-xr-x[-rw-r--r--]platform/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/platform/CMakeLists.txt b/platform/CMakeLists.txt
index bf3ea537c9..04b6e1f104 100644..100755
--- a/platform/CMakeLists.txt
+++ b/platform/CMakeLists.txt
@@ -44,6 +44,7 @@ target_sources(platform_s
ext/common/tfm_hal_its.c
ext/common/tfm_platform.c
ext/common/uart_stdout.c
+ ext/common/tfm_hal_spm_logdev_peripheral.c
$<$<BOOL:${PLATFORM_DUMMY_ATTEST_HAL}>:ext/common/template/attest_hal.c>
$<$<BOOL:${PLATFORM_DUMMY_NV_COUNTERS}>:ext/common/template/nv_counters.c>
$<$<BOOL:${PLATFORM_DUMMY_CRYPTO_KEYS}>:ext/common/template/crypto_keys.c>
@@ -61,6 +62,8 @@ target_link_libraries(platform_s
)
target_compile_definitions(platform_s
+ PUBLIC
+ TFM_SPM_LOG_LEVEL=${TFM_SPM_LOG_LEVEL}
PRIVATE
$<$<BOOL:${SYMMETRIC_INITIAL_ATTESTATION}>:SYMMETRIC_INITIAL_ATTESTATION>
)