aboutsummaryrefslogtreecommitdiff
path: root/interface/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'interface/CMakeLists.txt')
-rw-r--r--interface/CMakeLists.txt13
1 files changed, 1 insertions, 12 deletions
diff --git a/interface/CMakeLists.txt b/interface/CMakeLists.txt
index 3af7daa844..37ecfbc56d 100644
--- a/interface/CMakeLists.txt
+++ b/interface/CMakeLists.txt
@@ -15,7 +15,7 @@ if (TFM_MULTI_CORE_TOPOLOGY)
tfm_toolchain_reload_compiler()
# The platform target is created in this directory/file so that it has the
# same settings as the main ns target.
- add_library(platform_ns STATIC)
+ add_library(platform_ns STATIC EXCLUDE_FROM_ALL)
endif()
###################### PSA interface (header only) #############################
@@ -51,17 +51,6 @@ target_compile_definitions(psa_interface
$<$<BOOL:${FORWARD_PROT_MSG}>:FORWARD_PROT_MSG=${FORWARD_PROT_MSG}>
)
-# A dummy interface library to make sure platform NS build can proceed when NS
-# is disabled, if a platform doesn't use NS flag to control platform NS build.
-if (NOT NS)
- add_library(tfm_ns_interface INTERFACE)
-
- target_link_libraries(tfm_ns_interface
- INTERFACE
- psa_interface
- )
-endif()
-
###################### PSA api (S lib) #########################################
target_sources(tfm_secure_api