aboutsummaryrefslogtreecommitdiff
path: root/secure_fw/partitions/psa_proxy/CMakeLists.txt
diff options
context:
space:
mode:
authorMingyang Sun <mingyang.sun@arm.com>2021-04-02 16:51:05 +0800
committerMingyang Sun <mingyang.sun@arm.com>2021-05-08 16:23:14 +0800
commitf6a78572d5722a8e08d4e2bc1bcac8736e684eac (patch)
treea01392c5b3138fc8ef3b28fb4e4e4e02924e643d /secure_fw/partitions/psa_proxy/CMakeLists.txt
parent00df2357ff73936a6da5e94c41ccf7f9e7f11041 (diff)
downloadtrusted-firmware-m-f6a78572d5722a8e08d4e2bc1bcac8736e684eac.tar.gz
Build: Build and arrange partition static data
- Add a template to generate partition static data into dedicated source files. For the ns internal partition, manually add a source file for it. - Put these data into a dedicated memory section, to prepare for partition loading. Change-Id: Iad988608b04d2db9f5f43e7528f3ef21c1252f31 Signed-off-by: Mingyang Sun <mingyang.sun@arm.com>
Diffstat (limited to 'secure_fw/partitions/psa_proxy/CMakeLists.txt')
-rw-r--r--secure_fw/partitions/psa_proxy/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/secure_fw/partitions/psa_proxy/CMakeLists.txt b/secure_fw/partitions/psa_proxy/CMakeLists.txt
index 5db47e9b13..2a515df541 100644
--- a/secure_fw/partitions/psa_proxy/CMakeLists.txt
+++ b/secure_fw/partitions/psa_proxy/CMakeLists.txt
@@ -14,6 +14,7 @@ cmake_policy(SET CMP0079 NEW)
add_library(tfm_psa_rot_partition_psa_proxy STATIC)
+# Set include directory
target_include_directories(tfm_psa_rot_partition_psa_proxy
INTERFACE
$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>
@@ -22,6 +23,10 @@ target_include_directories(tfm_psa_rot_partition_psa_proxy
# Required for spm_ipc.h
$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>/../../spm/cmsis_psa
)
+target_include_directories(tfm_partitions
+ INTERFACE
+ ${CMAKE_BINARY_DIR}/generated/secure_fw/partitions/psa_proxy
+)
target_sources(tfm_psa_rot_partition_psa_proxy
PRIVATE
@@ -35,6 +40,10 @@ target_sources(tfm_psa_rot_partition_psa_proxy
PRIVATE
${CMAKE_BINARY_DIR}/generated/secure_fw/partitions/psa_proxy/auto_generated/intermedia_tfm_psa_proxy.c
)
+target_sources(tfm_partitions
+ INTERFACE
+ ${CMAKE_BINARY_DIR}/generated/secure_fw/partitions/psa_proxy/auto_generated/static_info_tfm_psa_proxy.c
+)
target_link_libraries(tfm_psa_rot_partition_psa_proxy
PRIVATE