aboutsummaryrefslogtreecommitdiff
path: root/secure_fw/CMakeLists.txt
diff options
context:
space:
mode:
authorRaef Coles <raef.coles@arm.com>2021-01-07 12:52:47 +0000
committerRaef Coles <raef.coles@arm.com>2021-01-19 10:07:52 +0000
commitdfe519bc8e2e7eaa692583a1c73a962cb1841c6e (patch)
tree8643f10adccaefdcff6195cb3c72fa6e716e9c0a /secure_fw/CMakeLists.txt
parentd45060aa47cefc047d8c68a7308d3fb0d93961dd (diff)
downloadtrusted-firmware-m-dfe519bc8e2e7eaa692583a1c73a962cb1841c6e.tar.gz
Build: add rot to cmake partition target names
change from tfm_partition_x to tfm_app_rot_partition_x or tfm_psa_rot_partition_x. This allows the linker to automtically pick up the library files and determine where they should be placed. Update TFM_TEST_REPO_VERSION to point to f1e9130c47f213a5380b00427770f61486b6e4fe, which is the head of the changes required for enabling this patch to work. Change-Id: If0b355f9e94a0ecc862c292302a573df1b3f9c2d Signed-off-by: Raef Coles <raef.coles@arm.com>
Diffstat (limited to 'secure_fw/CMakeLists.txt')
-rw-r--r--secure_fw/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/secure_fw/CMakeLists.txt b/secure_fw/CMakeLists.txt
index fbf857240c..364e2454db 100644
--- a/secure_fw/CMakeLists.txt
+++ b/secure_fw/CMakeLists.txt
@@ -1,5 +1,5 @@
#-------------------------------------------------------------------------------
-# Copyright (c) 2020, Arm Limited. All rights reserved.
+# Copyright (c) 2020-2021, Arm Limited. All rights reserved.
#
# SPDX-License-Identifier: BSD-3-Clause
#
@@ -120,12 +120,12 @@ if (TFM_CODE_SHARING)
set(LIB_LIST mbedcrypto
crypto_service_cc312
platform_s
- tfm_partition_crypto
- tfm_partition_audit
- tfm_partition_attestation
- tfm_partition_ps
- tfm_partition_its
- tfm_partition_platform
+ tfm_psa_rot_partition_crypto
+ tfm_psa_rot_partition_audit
+ tfm_psa_rot_partition_attestation
+ tfm_app_rot_partition_ps
+ tfm_psa_rot_partition_its
+ tfm_psa_rot_partition_platform
platform_s
tfm_sprt
tfm_spm