aboutsummaryrefslogtreecommitdiff
path: root/secure_fw/CMakeLists.txt
diff options
context:
space:
mode:
authorGyorgy Szing <Gyorgy.Szing@arm.com>2019-09-02 17:08:18 +0200
committerGyörgy Szing <gyorgy.szing@arm.com>2019-09-04 13:41:31 +0000
commitd9c57fb88e675b3edf13205077d55eaf24d9cf79 (patch)
treed5e32f0f1ea7c484f91ea53ff012dee0395111f9 /secure_fw/CMakeLists.txt
parent6714b45eb8983bdee4a9edbe849372ce20a088fb (diff)
downloadtrusted-firmware-m-d9c57fb88e675b3edf13205077d55eaf24d9cf79.tar.gz
Build: Fix pdf document build
CMake fails to generate proper rules for PDF generation both for the Reference Manual (doxygen) and for the user Guide. The problem is caused by CMAKE_MAKE_PROGRAM not being set when the document creation targets are defined. As a result CMake generates "empty" targets which do not execute the final step of PDF generation. The problem was triggered by project re-organization. To fix the problem document generation files are included after the project() command. Also the defined state of CMAKE_MAKE_PROGRAM is verified and a meaningful error message is printed to make the build more robust. In addition - I made some minor changes to make the document build related cmake files more consistent. - Fixed spelling issues. Change-Id: Id5d8dc756a50b3fee8966b51461ad3607d2027b4 Signed-off-by: Gyorgy Szing <Gyorgy.Szing@arm.com>
Diffstat (limited to 'secure_fw/CMakeLists.txt')
-rw-r--r--secure_fw/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/secure_fw/CMakeLists.txt b/secure_fw/CMakeLists.txt
index 79ff7675dc..196500748c 100644
--- a/secure_fw/CMakeLists.txt
+++ b/secure_fw/CMakeLists.txt
@@ -18,15 +18,15 @@ set(INTERFACE_DIR "${TFM_ROOT_DIR}/interface")
#Include common stuff to control cmake.
include("Common/BuildSys")
-#Include functionality to enable building the documentation.
-include("Common/BuildDoxygenDoc")
-include("Common/BuildSphinxDoc")
-
#Start an embedded project.
embedded_project_start(CONFIG "${TFM_ROOT_DIR}/configs/ConfigDefault.cmake")
project(tfm_s LANGUAGES ASM C)
embedded_project_fixup()
+#Include functionality to enable building the documentation.
+include("Common/BuildDoxygenDoc")
+include("Common/BuildSphinxDoc")
+
if (NOT DEFINED TFM_LVL)
message(FATAL_ERROR "Incomplete build configuration: TFM_LVL is undefined. ")
endif()