aboutsummaryrefslogtreecommitdiff
path: root/secure_fw/CMakeLists.txt
diff options
context:
space:
mode:
authorMingyang Sun <mingyang.sun@arm.com>2019-12-19 15:15:17 +0800
committerMingyang Sun <mingyang.sun@arm.com>2019-12-27 12:49:32 +0800
commitca25de5aeb94795755c1a23efb919f91da81b958 (patch)
tree64f0a824639b0dfc5d7033b376de3a247c0ea8d0 /secure_fw/CMakeLists.txt
parente5da4ad547a35ce7072d60fedbec1f29e27e5afb (diff)
downloadtrusted-firmware-m-ca25de5aeb94795755c1a23efb919f91da81b958.tar.gz
Test: Change printf to TEST_LOG
Replace all the 'printf' call to 'TEST_LOG', and use 'tfm_log_printf' instead of standard library 'printf'. Change-Id: Ie43009cf7ab35fe1fcd07500f41cf83129c37792 Signed-off-by: Mingyang Sun <mingyang.sun@arm.com>
Diffstat (limited to 'secure_fw/CMakeLists.txt')
-rw-r--r--secure_fw/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/secure_fw/CMakeLists.txt b/secure_fw/CMakeLists.txt
index fdc5371fc9..6a9b392b4c 100644
--- a/secure_fw/CMakeLists.txt
+++ b/secure_fw/CMakeLists.txt
@@ -218,8 +218,6 @@ function(set_up_secure_fw_build)
set(TARGET_COMPILE_DEFINITIONS __thumb2__ __DOMAIN_NS=0 DOMAIN_NS=__DOMAIN_NS __ARM_FEATURE_CMSE=${ARM_FEATURE_CMSE} TFM_LVL=${TFM_LVL} ${DEBUG_AUTHENTICATION})
embedded_set_target_compile_defines(TARGET ${PROJECT_OBJ_LIB} LANGUAGE C DEFINES ${TARGET_COMPILE_DEFINITIONS} APPEND)
- target_link_libraries(${EXE_NAME} libtfmsprt)
-
# The order of the libraries linked below is important for GCC
# Because the GCC linker will search an archive only once.
# If the a library has some symbols that are defined in the library which is linked before it,
@@ -260,6 +258,8 @@ function(set_up_secure_fw_build)
embedded_set_target_link_defines(TARGET ${EXE_NAME} DEFINES "TFM_PARTITION_PLATFORM")
endif()
+ target_link_libraries(${EXE_NAME} libtfmsprt)
+
embedded_set_target_link_defines(TARGET ${EXE_NAME} DEFINES "TFM_LVL=${TFM_LVL}")
if (TFM_PARTITION_TEST_CORE)