aboutsummaryrefslogtreecommitdiff
path: root/secure_fw/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Peng <kevin.peng@arm.com>2020-07-08 15:30:24 +0800
committerKevin Peng <kevin.peng@arm.com>2020-07-17 15:11:54 +0800
commitc5781480b8bbc2c3aae494d6e81f37ac12ef21d6 (patch)
tree4aac0e9aa0ff229495dd927ddbeae7d186de94b6 /secure_fw/CMakeLists.txt
parent7b299f55d51a5f75a0e84c5d51af61dcf20e3e8c (diff)
downloadtrusted-firmware-m-c5781480b8bbc2c3aae494d6e81f37ac12ef21d6.tar.gz
Build: Define TEST_DIR once and use it everywhere
The TEST_DIR was defined in multiple files and it was not used everywhere, some uses ${TFM_ROOT_DIR}/test instead. This patch unifies the TEST_DIR definition to CommonConfig.cmake and use it everywhere. Change-Id: I04d1104ad2453f4fa595b27b7a77146acf809e4f Signed-off-by: Kevin Peng <kevin.peng@arm.com>
Diffstat (limited to 'secure_fw/CMakeLists.txt')
-rw-r--r--secure_fw/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/secure_fw/CMakeLists.txt b/secure_fw/CMakeLists.txt
index 216c92aee7..336b4c8dde 100644
--- a/secure_fw/CMakeLists.txt
+++ b/secure_fw/CMakeLists.txt
@@ -14,7 +14,6 @@ list(APPEND CMAKE_MODULE_PATH ${CMAKE_CURRENT_LIST_DIR}/../cmake)
set(SECURE_FW_DIR "${CMAKE_CURRENT_LIST_DIR}")
set(TFM_ROOT_DIR "${SECURE_FW_DIR}/..")
-set(TEST_DIR "${TFM_ROOT_DIR}/test")
set(INTERFACE_DIR "${TFM_ROOT_DIR}/interface")
#Include common stuff to control cmake.
@@ -513,7 +512,7 @@ function(set_up_secure_fw_build)
endfunction()
#Adds the test directory
-add_subdirectory(${TFM_ROOT_DIR}/test ${CMAKE_BINARY_DIR}/test/secure_test)
+add_subdirectory(${TEST_DIR} ${CMAKE_BINARY_DIR}/test/secure_test)
#Add the crypto library target
if (TFM_PARTITION_CRYPTO)