aboutsummaryrefslogtreecommitdiff
path: root/secure_fw/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Hu <david.hu@arm.com>2019-10-10 14:32:53 +0800
committerDavid Hu <david.hu@arm.com>2020-02-20 09:09:56 +0800
commitaeaf273ab381e8c443cdad038ba8a468be7840c3 (patch)
treea38ef0c9615fb1cb4802b93e5c7e0d37c23e76f1 /secure_fw/CMakeLists.txt
parentecc9de8367a778b7516f2d197a0ebb0537d6e4ae (diff)
downloadtrusted-firmware-m-aeaf273ab381e8c443cdad038ba8a468be7840c3.tar.gz
Test: Add an option flag to control multi-core tests
Add an option flag TFM_MULTI_CORE_TEST to control multi-core specific tests. The multi-core platform should explicitly set it to ON to enable multi-core tests. Change-Id: I3f6e6aaa0ecaa109db1a503a26e05bb52f12f07c Signed-off-by: David Hu <david.hu@arm.com>
Diffstat (limited to 'secure_fw/CMakeLists.txt')
-rw-r--r--secure_fw/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/secure_fw/CMakeLists.txt b/secure_fw/CMakeLists.txt
index f59e1ef89f..73a14dac62 100644
--- a/secure_fw/CMakeLists.txt
+++ b/secure_fw/CMakeLists.txt
@@ -310,6 +310,11 @@ function(set_up_secure_fw_build)
embedded_set_target_link_defines(TARGET ${EXE_NAME} DEFINES "TFM_ENABLE_IRQ_TEST")
endif()
+ if (TFM_MULTI_CORE_TEST)
+ add_definitions(-DTFM_MULTI_CORE_TEST)
+ embedded_set_target_link_defines(TARGET ${EXE_NAME} DEFINES "TFM_MULTI_CORE_TEST")
+ endif()
+
#Generate binary file from executable
compiler_generate_binary_output(${EXE_NAME})