aboutsummaryrefslogtreecommitdiff
path: root/secure_fw/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Vincze <david.vincze@arm.com>2019-03-18 15:49:23 +0100
committerDavid Vincze <david.vincze@arm.com>2019-08-28 16:51:05 +0200
commit8bdfc2d24603e792599a2887383e9c88e244f3c8 (patch)
tree8cc9e67ef0679bdfe954ac72ca17e77c2df70411 /secure_fw/CMakeLists.txt
parent54d05556f6932f8c145a55f85d6c465310d4360f (diff)
downloadtrusted-firmware-m-8bdfc2d24603e792599a2887383e9c88e244f3c8.tar.gz
Boot: Replace flash partitioning terminology
This change replaces the slot 0/1 terminology with primary/secondary slot and replaces FLASH_AREA_IMAGE_0/1 with FLASH_AREA_IMAGE_PRIMARY/SECONDARY. This naming convention fits better to platforms with multiple images and it is also an architecture agnostic alternative. Change-Id: I5def429a076024831a702700736d9769a0b2301f Signed-off-by: David Vincze <david.vincze@arm.com>
Diffstat (limited to 'secure_fw/CMakeLists.txt')
-rw-r--r--secure_fw/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/secure_fw/CMakeLists.txt b/secure_fw/CMakeLists.txt
index 1fe005ade0..f6a8e53125 100644
--- a/secure_fw/CMakeLists.txt
+++ b/secure_fw/CMakeLists.txt
@@ -117,9 +117,9 @@ endif()
embedded_target_include_directories(TARGET ${PROJECT_OBJ_LIB} PATH ${TFM_ROOT_DIR} ABSOLUTE APPEND)
# For the non-swapping BL2 configuration two executables need to be built.
-# One can be executed from flash partition slot_0 and other from slot_1.
-# Only the linking phase is different. This function captures common settings
-# and eliminates copy-paste.
+# One can be executed from the primary slot flash partition and other from the
+# the secondary slot. Only the linking phase is different. This function
+# captures common settings and eliminates copy-paste.
function(set_up_secure_fw_build)
set( _OPTIONS_ARGS) #Option (on/off) arguments (e.g. IGNORE_CASE)
set( _ONE_VALUE_ARGS S_TARGET VENEER_NAME POSTFIX) #Single option arguments (e.g. PATH "./foo/bar")