aboutsummaryrefslogtreecommitdiff
path: root/secure_fw/CMakeLists.txt
diff options
context:
space:
mode:
authorMate Toth-Pal <mate.toth-pal@arm.com>2019-11-08 11:40:27 +0100
committerMate Toth-Pal <mate.toth-pal@arm.com>2019-12-04 13:03:31 +0100
commit179a1563b6ca2404a8a238b834c935de87900e92 (patch)
treeafab804b2669eda4b29e893efbb2946de2081623 /secure_fw/CMakeLists.txt
parentece03071816a3a0550d22ce7931170bed0acb5a0 (diff)
downloadtrusted-firmware-m-179a1563b6ca2404a8a238b834c935de87900e92.tar.gz
Interface: Enable Platform service in IPC model
Enable Platform Secure service in IPC model - modify Cmake files to build the service for IPC model - create NS API source file - add IPC model implementation to secure API file - add services to Platform Secure partition's yaml file - declare IPC support for the Platform Secure partition in tfm_manifest_list.yaml - enable reset service /SPM request in IPC mode Change-Id: I553b7c64bb90c65e6200c619b7c0b30881bf490f Signed-off-by: Mate Toth-Pal <mate.toth-pal@arm.com>
Diffstat (limited to 'secure_fw/CMakeLists.txt')
-rw-r--r--secure_fw/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/secure_fw/CMakeLists.txt b/secure_fw/CMakeLists.txt
index 6cc8d6ce70..59b5095c71 100644
--- a/secure_fw/CMakeLists.txt
+++ b/secure_fw/CMakeLists.txt
@@ -344,8 +344,13 @@ function(set_up_secure_fw_build)
if(TFM_PARTITION_PLATFORM)
install(FILES ${INTERFACE_INC_DIR}/tfm_platform_api.h
DESTINATION ${EXPORT_INC_DIR})
- install(FILES ${INTERFACE_SRC_DIR}/tfm_platform_func_api.c
- DESTINATION ${EXPORT_SRC_DIR})
+ if(TFM_PSA_API)
+ install(FILES ${INTERFACE_SRC_DIR}/tfm_platform_ipc_api.c
+ DESTINATION ${EXPORT_SRC_DIR})
+ else()
+ install(FILES ${INTERFACE_SRC_DIR}/tfm_platform_func_api.c
+ DESTINATION ${EXPORT_SRC_DIR})
+ endif()
endif()
install(FILES ${S_VENEER_FILE} DESTINATION export/tfm/veneers)