aboutsummaryrefslogtreecommitdiff
path: root/platform/CMakeLists.txt
diff options
context:
space:
mode:
authorMichel Jaouen <michel.jaouen@st.com>2020-09-25 16:59:04 +0200
committerTamas Ban <tamas.ban@arm.com>2020-10-27 13:15:40 +0000
commitca57edfcbfc6cd7274c049c54f4cacfe1ce3bd1b (patch)
tree9a3d0f950ba09088482024ad430e0b2656053cb1 /platform/CMakeLists.txt
parent45c6c204d509a2a04031744680060abe43bf49db (diff)
downloadtrusted-firmware-m-ca57edfcbfc6cd7274c049c54f4cacfe1ce3bd1b.tar.gz
Platform: Rework dummy crypto_key and tfm_rotpk to fix unresolved at
tfm_s link with ARMCLANG In case of build with PLATFORM_DUMMY_CRYPTO_KEYS, crypto_key is include in bl2 to provide tfm_plat_get_rotpk_hash used by bl2 only. When compiling secure without tfm_rotpk, device_rotpk is unresolved With ARMCLANG even if tfm_plat_get_rotpk_hash is not used by secure. Change-Id: Ifb5e51a2dff327bba2233d34302efdaf006cec6d Signed-off-by: Michel Jaouen <michel.jaouen@st.com>
Diffstat (limited to 'platform/CMakeLists.txt')
-rw-r--r--platform/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/platform/CMakeLists.txt b/platform/CMakeLists.txt
index aaad44ea09..bf3ea537c9 100644
--- a/platform/CMakeLists.txt
+++ b/platform/CMakeLists.txt
@@ -113,7 +113,6 @@ if(BL2)
ext/common/uart_stdout.c
ext/common/boot_hal.c
$<$<BOOL:${PLATFORM_DUMMY_NV_COUNTERS}>:ext/common/template/nv_counters.c>
- $<$<BOOL:${PLATFORM_DUMMY_CRYPTO_KEYS}>:ext/common/template/crypto_keys.c>
$<$<BOOL:${PLATFORM_DUMMY_ROTPK}>:ext/common/template/tfm_rotpk.c>
$<$<BOOL:${PLATFORM_DUMMY_IAK}>:ext/common/template/tfm_initial_attestation_key_material.c>
)