aboutsummaryrefslogtreecommitdiff
path: root/platform/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Hu <david.hu@arm.com>2020-11-23 17:08:32 +0800
committerDavid Hu <david.hu@arm.com>2021-01-22 02:21:55 +0000
commitbe31873bcabe7737cf3bff13f60da7c0f3bc9458 (patch)
tree62e0f995c74f76221d647c74aa73b0f6f27fa22d /platform/CMakeLists.txt
parent8b526d4544a8d1e3aa98ac2101b1f818cc0dd888 (diff)
downloadtrusted-firmware-m-be31873bcabe7737cf3bff13f60da7c0f3bc9458.tar.gz
Build: Improve NS mailbox config flag setting
Support a flag TFM_MULTI_CORE_NS_OS to control NS integration. When integrating TF-M with NS OS on dual-cpu platforms, select TFM_MULTI_CORE_NS_OS in NS build to enable NS OS support in NS mailbox. When integrating TF-M with NS bare metal environment, disable TFM_MULTI_CORE_NS_OS and NS mailbox relies on looping and requires no support from NS OS. TFM_MULTI_CORE_MULTI_CLIENT_CALL is removed. NS mailbox build can get rid of the dependency on the configuration of TFM_MULTI_CORE_MULTI_CLIENT_CALL in S mailbox build. NUM_MAILBOX_QUEUE_SLOT directly indicates whether platform and SPE supports multiple NS PSA Client calls. Change-Id: I937b2afdb88cccc22a20617d2ab36bcc1b939b05 Signed-off-by: David Hu <david.hu@arm.com>
Diffstat (limited to 'platform/CMakeLists.txt')
-rwxr-xr-xplatform/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/platform/CMakeLists.txt b/platform/CMakeLists.txt
index 5e493b1341..93f50680cf 100755
--- a/platform/CMakeLists.txt
+++ b/platform/CMakeLists.txt
@@ -1,5 +1,5 @@
#-------------------------------------------------------------------------------
-# Copyright (c) 2020, Arm Limited. All rights reserved.
+# Copyright (c) 2020-2021, Arm Limited. All rights reserved.
#
# SPDX-License-Identifier: BSD-3-Clause
#
@@ -96,7 +96,6 @@ target_compile_definitions(platform_ns
PRIVATE
$<$<BOOL:${TFM_IRQ_TEST}>:TFM_ENABLE_IRQ_TEST>
$<$<BOOL:${TFM_PERIPH_ACCESS_TEST}>:TFM_ENABLE_PERIPH_ACCESS_TEST>
- $<$<BOOL:${TFM_MULTI_CORE_MULTI_CLIENT_CALL}>:TFM_MULTI_CORE_MULTI_CLIENT_CALL>
)
#========================= Platform BL2 =======================================#