aboutsummaryrefslogtreecommitdiff
path: root/platform/CMakeLists.txt
diff options
context:
space:
mode:
authorMingyang Sun <mingyang.sun@arm.com>2020-12-07 10:45:17 +0800
committerMingyang Sun <mingyang.sun@arm.com>2021-01-06 10:22:44 +0800
commit9763dee6fdc533fda5f334b2df976db39569f4dd (patch)
treead045d53527d4857e9942cd5cd35a3ed3dad565b /platform/CMakeLists.txt
parenta891d4f8f0c931a6f79f13c15c2233e49598a13e (diff)
downloadtrusted-firmware-m-9763dee6fdc533fda5f334b2df976db39569f4dd.tar.gz
Build: Put CONFIG_TFM_ENABLE_MEMORY_PROTECT flag to platform
The flag "CONFIG_TFM_ENABLE_MEMORY_PROTECT" is a platform-scope option, move it to platform_s target. Remove the isolation setup in library SPM code and reuse the one of SPM HAL, since they are doing the same things. Change-Id: I5766ddecc525ee2eda3f2e5989b31dd5c41fde6b Signed-off-by: Mingyang Sun <mingyang.sun@arm.com>
Diffstat (limited to 'platform/CMakeLists.txt')
-rwxr-xr-xplatform/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/platform/CMakeLists.txt b/platform/CMakeLists.txt
index 6cd9befdfb..85f2c38b17 100755
--- a/platform/CMakeLists.txt
+++ b/platform/CMakeLists.txt
@@ -66,6 +66,7 @@ target_compile_definitions(platform_s
TFM_SPM_LOG_LEVEL=${TFM_SPM_LOG_LEVEL}
PRIVATE
$<$<BOOL:${SYMMETRIC_INITIAL_ATTESTATION}>:SYMMETRIC_INITIAL_ATTESTATION>
+ $<$<OR:$<VERSION_GREATER:${TFM_ISOLATION_LEVEL},1>,$<STREQUAL:"${TEST_PSA_API}","IPC">>:CONFIG_TFM_ENABLE_MEMORY_PROTECT>
)
#========================= Platform Non-Secure ================================#