aboutsummaryrefslogtreecommitdiff
path: root/platform/CMakeLists.txt
diff options
context:
space:
mode:
authorØyvind Rønningstad <oyvind.ronningstad@nordicsemi.no>2020-12-01 15:26:39 +0100
committerDavid Hu <david.hu@arm.com>2020-12-15 13:24:25 +0000
commit1dab74ba8d7b6acbe45dfeac9264a9f1c8c8eb86 (patch)
tree3cafe541e3c663adc8c5bf32bdd38f516521fae2 /platform/CMakeLists.txt
parent5a212ec8141ddf720a328d7a37d49c3b9095158f (diff)
downloadtrusted-firmware-m-1dab74ba8d7b6acbe45dfeac9264a9f1c8c8eb86.tar.gz
Build: Support out-of-tree platforms
Allows -DTFM_PLATFORM to be set to paths outside the TFM tree. e.g. cmake ... -DTFM_PLATFORM=../../../../tfm_platforms/my_platform Note: TFM_PLATFORM currently only accepts paths relative from platform/ext/target Change-Id: I99d194fdee43ffa29da67b22eb79ef5e450c1559 Signed-off-by: Øyvind Rønningstad <oyvind.ronningstad@nordicsemi.no>
Diffstat (limited to 'platform/CMakeLists.txt')
-rwxr-xr-xplatform/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/platform/CMakeLists.txt b/platform/CMakeLists.txt
index b03c88ec95..915307cf12 100755
--- a/platform/CMakeLists.txt
+++ b/platform/CMakeLists.txt
@@ -23,7 +23,7 @@ endif()
set(PLATFORM_DIR ${CMAKE_CURRENT_LIST_DIR})
-add_subdirectory(ext/target/${TFM_PLATFORM})
+add_subdirectory(ext/target/${TFM_PLATFORM} target)
#========================= Platform Secure ====================================#