aboutsummaryrefslogtreecommitdiff
path: root/platform/CMakeLists.txt
diff options
context:
space:
mode:
authorRaef Coles <raef.coles@arm.com>2021-08-10 16:55:40 +0100
committerRaef Coles <raef.coles@arm.com>2021-10-07 09:10:40 +0100
commit12c642c832e6f18af2f0d780f68cedb5c642a94e (patch)
tree581c43f764f0f9dffb554d429e9b89a52c4369a3 /platform/CMakeLists.txt
parenta8f1ddf6cd1cb4f5f67918d3cb836a829395790a (diff)
downloadtrusted-firmware-m-12c642c832e6f18af2f0d780f68cedb5c642a94e.tar.gz
Platform: Update Diphda BL1 cmake
To be more easily extensible, and avoid potential compilation issues with the use of the BL1 flag. Change-Id: I02aae694637ff25acee19b8652147e9195f18111 Signed-off-by: Raef Coles <raef.coles@arm.com>
Diffstat (limited to 'platform/CMakeLists.txt')
-rwxr-xr-xplatform/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/platform/CMakeLists.txt b/platform/CMakeLists.txt
index 7bc845bbdc..1db3208ab4 100755
--- a/platform/CMakeLists.txt
+++ b/platform/CMakeLists.txt
@@ -160,6 +160,7 @@ endif()
#TODO maybe just link the other platforms to this
target_compile_definitions(platform_region_defs
INTERFACE
+ $<$<BOOL:${BL1}>:BL1>
$<$<BOOL:${BL2}>:BL2>
$<$<BOOL:${SECURE_UART1}>:SECURE_UART1>
DAUTH_${DEBUG_AUTHENTICATION}