aboutsummaryrefslogtreecommitdiff
path: root/platform/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Vincze <david.vincze@linaro.org>2020-11-25 19:02:57 +0100
committerTamas Ban <tamas.ban@arm.com>2020-12-01 08:40:35 +0000
commit0c515de58451a8d333093c4a187d332636d6df14 (patch)
tree61073c61cb3a0502de1ae0cc42d396eb33284c22 /platform/CMakeLists.txt
parentdace16c5209b9c1c798c369c8dfb447c1ff93096 (diff)
downloadtrusted-firmware-m-0c515de58451a8d333093c4a187d332636d6df14.tar.gz
Build: Check MCUboot strategy configuration
Validate the value of the MCUBOOT_UPGRADE_STRATEGY variable and set the accepted values for its cache entry. It helps to avoid misconfiguration which can remain hidden. Remove unused UPGRADE_STRATEGY string variable and unnecessary check. Change-Id: I6b8529dafe51cbaf2b26a5ac56a710c9687812ae Signed-off-by: David Vincze <david.vincze@linaro.org>
Diffstat (limited to 'platform/CMakeLists.txt')
-rwxr-xr-xplatform/CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/platform/CMakeLists.txt b/platform/CMakeLists.txt
index f73bd9d028..37ce6e5032 100755
--- a/platform/CMakeLists.txt
+++ b/platform/CMakeLists.txt
@@ -129,12 +129,6 @@ if(BL2)
tfm_arch
)
- if (NOT DEFINED MCUBOOT_UPGRADE_STRATEGY)
- message(FATAL_ERROR "MCUBOOT_UPGRADE_STRATEGY is undefined")
- else()
- string(CONCAT UPGRADE_STRATEGY "MCUBOOT_" ${MCUBOOT_UPGRADE_STRATEGY})
- endif()
-
target_compile_definitions(platform_bl2
PUBLIC
BL2