aboutsummaryrefslogtreecommitdiff
path: root/bl2/CMakeLists.txt
diff options
context:
space:
mode:
authorFeder Liang <Feder.Liang@arm.com>2021-09-07 15:34:46 +0800
committerDavid Hu <david.hu@arm.com>2021-11-16 11:25:58 +0100
commitd4dbaa93d0f3d1616e583aec80fc4b771a4c545b (patch)
tree0270305311cd25323984172b2a9c88523617e03b /bl2/CMakeLists.txt
parent42f5b56278eaa797e0ab81d13099d81979abba57 (diff)
downloadtrusted-firmware-m-d4dbaa93d0f3d1616e583aec80fc4b771a4c545b.tar.gz
SPM: Add FPU support for gnu arm embedded toolchain
1. Enable FP support in SPE by CONFIG_TFM_SPE_FP (0:software, 1:hybird, 2:hardware) for IPC model. It doesn't support LIBRARY model. 2. Enable lazy stacking from SPE by CONFIG_TFM_LAZY_STACKING_SPE (OFF, ON). 3. Separate qcbor, t_cose for SPE and NSPE. Note: NSPE is not allowed to use FPU at current stage when FPU is enabled for SPE. Change-Id: I856fdcccbbc403c5ec3689d95df4d082f106ff47 Signed-off-by: Feder Liang <Feder.Liang@arm.com>
Diffstat (limited to 'bl2/CMakeLists.txt')
-rw-r--r--bl2/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/bl2/CMakeLists.txt b/bl2/CMakeLists.txt
index 3cba7adb82..5cfef484aa 100644
--- a/bl2/CMakeLists.txt
+++ b/bl2/CMakeLists.txt
@@ -36,6 +36,11 @@ target_link_libraries(bl2
tfm_boot_status
)
+target_compile_options(bl2
+ PRIVATE
+ ${BL2_COMPILER_CP_FLAG}
+)
+
target_link_options(bl2
PRIVATE
$<$<C_COMPILER_ID:GNU>:-Wl,-Map=${CMAKE_BINARY_DIR}/bin/bl2.map>
@@ -110,6 +115,21 @@ target_include_directories(bl2_mbedcrypto
${MBEDCRYPTO_PATH}/library
)
+target_compile_options(bl2_mbedcrypto
+ PRIVATE
+ ${BL2_COMPILER_CP_FLAG}
+)
+
+target_compile_options(bl2_mbedtls
+ PRIVATE
+ ${BL2_COMPILER_CP_FLAG}
+)
+
+target_compile_options(bl2_mbedx509
+ PRIVATE
+ ${BL2_COMPILER_CP_FLAG}
+)
+
############################### CODE SHARING ###################################
if (TFM_CODE_SHARING)