aboutsummaryrefslogtreecommitdiff
path: root/bl2/CMakeLists.txt
diff options
context:
space:
mode:
authorTTornblom <thomas.tornblom@iar.com>2020-09-29 13:26:29 +0200
committerTamas Ban <tamas.ban@arm.com>2020-10-29 10:08:44 +0000
commitaf19ae94ac7acb4c4cac06138eafac221d0ddb2a (patch)
tree067e9b15757a150007defbfa139a154ba53a0ae0 /bl2/CMakeLists.txt
parent539db732035cf9325cdbf79bdbd5164f45341fbc (diff)
downloadtrusted-firmware-m-af19ae94ac7acb4c4cac06138eafac221d0ddb2a.tar.gz
Build: Update IAR cmake files, fix Windows build errors
Fixed regex issue in toolchain_IARARM.cmake, causing Windows build errors Moved --map option from toolchain file to CMakeLists.txt files, like for ARMClang and GNUARM Removed dead code from toolchain_IARARM.cmake Renamed IAR RTX libraries in CMakeLists.txt Signed-off-by: TTornblom <thomas.tornblom@iar.com> Change-Id: I01805f59a5be0ca4cd2bf47f20dd4a8852c1ea54
Diffstat (limited to 'bl2/CMakeLists.txt')
-rw-r--r--bl2/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/bl2/CMakeLists.txt b/bl2/CMakeLists.txt
index b49677e65a..6199eda07d 100644
--- a/bl2/CMakeLists.txt
+++ b/bl2/CMakeLists.txt
@@ -38,6 +38,7 @@ target_link_options(bl2
PRIVATE
$<$<C_COMPILER_ID:GNU>:-Wl,-Map=${CMAKE_BINARY_DIR}/bin/bl2.map>
$<$<C_COMPILER_ID:ARMClang>:--map>
+ $<$<C_COMPILER_ID:IAR>:--map\;${CMAKE_BINARY_DIR}/bin/bl2.map>
)
add_convert_to_bin_target(bl2)