aboutsummaryrefslogtreecommitdiff
path: root/bl2/CMakeLists.txt
diff options
context:
space:
mode:
authorAntonio de Angelis <Antonio.deAngelis@arm.com>2021-10-21 11:39:04 +0100
committerAntonio de Angelis <Antonio.deAngelis@arm.com>2021-10-21 15:49:13 +0100
commit9e7e378a3b4248ca02170f5ce5805d4be1bb23b9 (patch)
tree343eaad1fa21f6643d384f8a88c363ef2ea8de1c /bl2/CMakeLists.txt
parent51fa26f65f2d868bab16c6121ce1b5462e703c88 (diff)
downloadtrusted-firmware-m-9e7e378a3b4248ca02170f5ce5805d4be1bb23b9.tar.gz
Build: Fixes on target names and dependencies
Do not set mbedTLS target names explictly but just use the MBEDTLS_TARGET_PREFIX variable. Also, enforce depedency in BL2 between platform (boot_hal) and the bl2_crypto_hw target which is missed currently. Signed-off-by: Antonio de Angelis <antonio.deangelis@arm.com> Change-Id: I9300d2eca775f0027889937822aff271537c6b29
Diffstat (limited to 'bl2/CMakeLists.txt')
-rw-r--r--bl2/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/bl2/CMakeLists.txt b/bl2/CMakeLists.txt
index c5626d785b..a6487b0ed7 100644
--- a/bl2/CMakeLists.txt
+++ b/bl2/CMakeLists.txt
@@ -83,10 +83,7 @@ set(ENABLE_DOCS OFF)
set(INSTALL_MBEDTLS_HEADERS OFF)
set(LIB_INSTALL_DIR ${CMAKE_CURRENT_BINARY_DIR}/mbedcrypto/install)
-set(lib_target bl2_mbedcrypto_libs)
-set(mbedcrypto_target bl2_mbedcrypto)
-set(mbedtls_target bl2_mbedtls)
-set(mbedx509_target bl2_mbedx509)
+# Set the prefix to be used by mbedTLS targets
set(MBEDTLS_TARGET_PREFIX bl2_)
# Mbedcrypto is quite a large lib, and it uses too much memory for it to be