aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRaef Coles <raef.coles@arm.com>2020-11-24 14:27:52 +0000
committerAnton Komlev <Anton.Komlev@arm.com>2020-11-24 19:26:23 +0000
commitfbc34ccd17ede0737ce09106c453fa29226d10d4 (patch)
tree11b82ad06e91c28b606989144b2cb88344ca6489 /CMakeLists.txt
parent04d47bb2f9a9e061064d567662325b1efeab8da8 (diff)
downloadtrusted-firmware-m-fbc34ccd17ede0737ce09106c453fa29226d10d4.tar.gz
Explicitly disable FPU, MVE and DSP support
In the secure world. NS can be configured as normal using preload_ns. Change-Id: I0ae795792382ff56006bded9fe1c75083b8d7a6a Signed-off-by: Raef Coles <raef.coles@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 40882c2d93..6bfafb120c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,16 @@ else()
include(platform/ext/target/${TFM_PLATFORM}/preload.cmake)
endif()
+if(TFM_SYSTEM_FP)
+ message(FATAL_ERROR "Hardware FPU is currently not supported in TF-M")
+endif()
+if(TFM_SYSTEM_MVE)
+ message(FATAL_ERROR "Hardware MVE is currently not supported in TF-M")
+endif()
+if(TFM_SYSTEM_DSP)
+ message(FATAL_ERROR "Hardware DSP is currently not supported in TF-M")
+endif()
+
include(config/set_config.cmake)
if(NOT ${CMAKE_GENERATOR} STREQUAL "Unix Makefiles" AND