aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Vincze <david.vincze@arm.com>2020-01-06 17:31:11 +0100
committerDavid Vincze <david.vincze@arm.com>2020-01-27 14:54:42 +0100
commitc3e313a37c583ffbc8042656ad59e7cda6fd656c (patch)
tree7b04b36e3721945284ca9f069bcac393cc8b801a /CMakeLists.txt
parente13a48b65321a8828bd9e3a11e1652436df6c6b0 (diff)
downloadtrusted-firmware-m-c3e313a37c583ffbc8042656ad59e7cda6fd656c.tar.gz
Build: Enable building TF-M with original MCUBoot
Enable building TF-M with the original MCUBoot (alongside the forked one in the TF-M repository). Before building with the upstream MCUBoot repo, it must be cloned into the TF-M base folder (into which the TF-M was cloned previously) and the -DMCUBOOT_REPO=UPSTREAM option must be added to the command line at the CMake configuration step. The MCUBOOT_REPO option determines the repository from which it will use the MCUBoot. By default it will use it from the TF-M repository. Add description of how to build TF-M with upstream MCUBoot to the documentation. Change-Id: I2cfa55039943a9ac919156570120367d9603a816 Signed-off-by: David Vincze <david.vincze@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4dd21e692b..ab4ce73466 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
#-------------------------------------------------------------------------------
-# Copyright (c) 2017-2019, Arm Limited. All rights reserved.
+# Copyright (c) 2017-2020, Arm Limited. All rights reserved.
#
# SPDX-License-Identifier: BSD-3-Clause
#
@@ -12,7 +12,9 @@ include("Common/BuildSys")
add_subdirectory(secure_fw)
add_subdirectory(app)
-add_subdirectory(bl2/ext/mcuboot)
+if (BL2)
+ add_subdirectory(bl2/ext/mcuboot)
+endif()
#Define a top-level generic tfm project
project(tfm LANGUAGES)